A class representing a handle on a Rebar that can be joined to a reference, such
as a host Element's surface or cover, or another Rebar's handle.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since:
2014
Syntax
C# |
---|
public class RebarConstrainedHandle : IDisposable |
Visual Basic |
---|
Public Class RebarConstrainedHandle _ Implements IDisposable |
Visual C++ |
---|
public ref class RebarConstrainedHandle : IDisposable |
Remarks
A rebar element's flexible geometry is controlled by several handles. The shape of the bar is controlled by a handle at each end of the bar (blue circle controls) and a handle each edge (blue triangle controls). Another handle is used to control the location of the plane in which the rebar lies. An additional handle controls the length of a set of rebar.
RebarConstrainedHandles can only be constructed internally by Revit. They are available to the API by querying a rebar element's RebarConstraintsManager.