A constraint which can be applied to a RebarShapeSegment, and causes the segment
to be replaced with a 180-degree arc. The associated parameter drives
the radius of the arc.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since:
2012
Syntax
C# |
---|
public class RebarShapeConstraint180DegreeBendRadius : RebarShapeConstraint |
Visual Basic |
---|
Public Class RebarShapeConstraint180DegreeBendRadius _ Inherits RebarShapeConstraint |
Visual C++ |
---|
public ref class RebarShapeConstraint180DegreeBendRadius : public RebarShapeConstraint |
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint180DegreeBendRadius
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint180DegreeBendRadius