Revit 2017 API |
FabricWireItem..::..Create Method |
FabricWireItem Class See Also |
Creates a new instance of a single Fabric wire.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since:
2017
Syntax
C# |
---|
public static FabricWireItem Create( double distance, double wireLength, ElementId wireType ) |
Visual Basic |
---|
Public Shared Function Create ( _ distance As Double, _ wireLength As Double, _ wireType As ElementId _ ) As FabricWireItem |
Visual C++ |
---|
public: static FabricWireItem^ Create( double distance, double wireLength, ElementId^ wireType ) |
Parameters
- distance
- Type: System..::..Double
The distance between this wire and the next wire in the Custom Fabric Sheet
- wireLength
- Type: System..::..Double
Length of this wire
- wireType
- Type: Autodesk.Revit.DB..::..ElementId
The wire type of this wire
Return Value
The newly created Fabric wire instance.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for distance is not a number -or- The given value for wireLength is not a number -or- wireType is not a valid Element identifier. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for distance must be greater than 0 and no more than 30000 feet. -or- The given value for wireLength must be greater than 0 and no more than 30000 feet. |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |