Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Syntax
C# |
---|
public class RebarShapeDefinitionBySegments : RebarShapeDefinition |
Visual Basic |
---|
Public Class RebarShapeDefinitionBySegments _ Inherits RebarShapeDefinition |
Visual C++ |
---|
public ref class RebarShapeDefinitionBySegments : public RebarShapeDefinition |
Remarks
The segments are represented by RebarShapeEdge objects. The segments are numbered starting with 0, and they have a direction; so the beginning of the shape is end 0 of segment 0, and the end of the shape is end 1 of segment (NumberOfSegments-1).
The ends and junctions are represented by RebarShapeVertex objects. The number of vertices is always one greater than the number of segments. The first vertex represents the start of the shape; the last vertex represents the end of the shape; and the intermediate vertices represent the bends between segments.
Inheritance Hierarchy
Autodesk.Revit.DB.Structure..::..RebarShapeDefinition
Autodesk.Revit.DB.Structure..::..RebarShapeDefinitionBySegments