Revit 2019.1 API |
Application..::..NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, StructuralType) |
Application Class See Also |
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.1.0.0)
Syntax
C# |
---|
public FamilyInstanceCreationData NewFamilyInstanceCreationData( XYZ location, FamilySymbol symbol, Element host, StructuralType structuralType ) |
Visual Basic |
---|
Public Function NewFamilyInstanceCreationData ( _ location As XYZ, _ symbol As FamilySymbol, _ host As Element, _ structuralType As StructuralType _ ) As FamilyInstanceCreationData |
Visual C++ |
---|
public: FamilyInstanceCreationData^ NewFamilyInstanceCreationData( XYZ^ location, FamilySymbol^ symbol, Element^ host, StructuralType structuralType ) |
Parameters
- location
- Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
- symbol
- Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
- host
- Type: Autodesk.Revit.DB..::..Element
The object into which the family instance is to be inserted, often known as the host.
- structuralType
- Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.