Revit 2019.1 API |
IFCAnyHandle..::..SetAttribute Method (String, IFCAnyHandle) |
IFCAnyHandle Class See Also |
Sets the attribute value.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 19.0.0.0 (19.1.0.0)
Since:
2013
Syntax
C# |
---|
public void SetAttribute( string name, IFCAnyHandle value ) |
Visual Basic |
---|
Public Sub SetAttribute ( _ name As String, _ value As IFCAnyHandle _ ) |
Visual C++ |
---|
public: void SetAttribute( String^ name, IFCAnyHandle^ value ) |
Parameters
- name
- Type: System..::..String
The attribute name.
- value
- Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The value.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |