IFC transactions are context-like objects that guard any changes made to an IFC file.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 19.0.0.0 (19.1.0.0)
Since:
2012
Syntax
C# |
---|
public class IFCTransaction : IDisposable |
Visual Basic |
---|
Public Class IFCTransaction _ Implements IDisposable |
Visual C++ |
---|
public ref class IFCTransaction : IDisposable |
Remarks
Any change to an IFC file can only be made while there is an active transaction
open for that file. Changes do not become a part of the file until the
active transaction is committed. Consequently, all
changes made in a transaction can be rolled back
either explicitly or implicitly (by the destructor).