The base class for exceptions that are
common to both file-based and server-based central models or
specific to just file-based central models.
Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2014
Syntax
C# |
---|
[SerializableAttribute] public class CentralModelException : ApplicationException |
Visual Basic |
---|
<SerializableAttribute> _ Public Class CentralModelException _ Inherits ApplicationException |
Visual C++ |
---|
[SerializableAttribute] public ref class CentralModelException : public ApplicationException |
Inheritance Hierarchy
System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..CentralModelException
Autodesk.Revit.Exceptions..::..CentralFileCommunicationException
Autodesk.Revit.Exceptions..::..CentralModelAccessDeniedException
Autodesk.Revit.Exceptions..::..CentralModelAlreadyExistsException
Autodesk.Revit.Exceptions..::..CentralModelContentionException
Autodesk.Revit.Exceptions..::..OutdatedDirectlyOpenedCentralException
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..CentralModelException
Autodesk.Revit.Exceptions..::..CentralFileCommunicationException
Autodesk.Revit.Exceptions..::..CentralModelAccessDeniedException
Autodesk.Revit.Exceptions..::..CentralModelAlreadyExistsException
Autodesk.Revit.Exceptions..::..CentralModelContentionException
Autodesk.Revit.Exceptions..::..OutdatedDirectlyOpenedCentralException