Revit Preview Release API |
FamilyType..::..AsDouble Method |
FamilyType Class See Also |
Provides access to the double precision number of the given family parameter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Syntax
C# |
---|
public Nullable<double> AsDouble( FamilyParameter familyParameter ) |
Visual Basic |
---|
Public Function AsDouble ( _ familyParameter As FamilyParameter _ ) As Nullable(Of Double) |
Visual C++ |
---|
public: Nullable<double> AsDouble( FamilyParameter^ familyParameter ) |
Parameters
- familyParameter
- Type: Autodesk.Revit.DB..::..FamilyParameter
Return Value
The double value contained in the parameter. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the storage type of the input argument is not double type or this parameter has no value.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"familyParameter"-is invalid, |