Revit Preview Release API |
Curve..::..IsInside Method (Double) |
Curve Class See Also |
Indicates whether the specified parameter value is within this curve's bounds.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Syntax
C# |
---|
public bool IsInside( double parameter ) |
Visual Basic |
---|
Public Function IsInside ( _ parameter As Double _ ) As Boolean |
Visual C++ |
---|
public: bool IsInside( double parameter ) |
Parameters
- parameter
- Type: System..::..Double
The raw curve parameter to be evaluated.
Return Value
True if the parameter is within the bounds, otherwise false.
Remarks
Always returns true if this curve is unbound.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified parameter is infinite. |