Indicates whether this is a reporting global parameter or not.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since:
2016 Subscription Update
Syntax
C# |
---|
public bool IsReporting { get; set; } |
Visual Basic |
---|
Public Property IsReporting As Boolean
Get
Set |
Visual C++ |
---|
public:
property bool IsReporting {
bool get ();
void set (bool value);
} |
Field Value
True if the parameter is reporting, False otherwise.
Remarks
Exceptions
Exception | Condition |
---|
Autodesk.Revit.Exceptions..::..ArgumentException |
When setting this property: This is a formula-driven parameter. As such it does not allow the current operation.
-or-
When setting this property: This non-reporting global parameter has already labeled other dimensions (more then 1).
It cannot, therefore, be made reporting and dimension-driven before un-labeling all
the dependent dimensions first.
-or-
When setting this property: The global parameter is not of a type that may be used with reporting.
Generally, a reporting parameter must be either of type Length or Angle.
-or-
When setting this property: Currently reporting parameters may not be changed if they are driven by a dimension that cannot
have its value set by a global parameter, such as an arc-length, locked, or multi-segment dimension.
|
See Also