Revit Preview Release API |
PanelScheduleView..::..GenerateInstanceFromTemplate Method |
PanelScheduleView Class See Also |
Assigns the data from the template to the instance and performs any tasks specific to the instance (3rd phase, borders, etc)
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Syntax
C# |
---|
public void GenerateInstanceFromTemplate( ElementId templateId ) |
Visual Basic |
---|
Public Sub GenerateInstanceFromTemplate ( _ templateId As ElementId _ ) |
Visual C++ |
---|
public: void GenerateInstanceFromTemplate( ElementId^ templateId ) |
Parameters
- templateId
- Type: Autodesk.Revit.DB..::..ElementId
Element id of the template element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |