Returns a new XYZ whose coordinates are the normalized values from this vector.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Syntax
C# |
---|
public XYZ Normalize() |
Visual Basic |
---|
Public Function Normalize As XYZ |
Visual C++ |
---|
public: XYZ^ Normalize() |
Return Value
The normalized XYZ or zero if the vector is almost Zero.
Remarks
Normalized indicates that the length of this vector equals one (a unit vector).