Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.
Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Syntax
C# |
---|
public class Application : IDisposable |
Visual Basic |
---|
Public Class Application _ Implements IDisposable |
Visual C++ |
---|
public ref class Application : IDisposable |
Examples

string versionInfo = application.VersionBuild + "\n" + application.VersionName + "\n" + application.VersionNumber;

Dim versionInfo As String = (application.VersionBuild + vbLf + application.VersionName & vbLf) + application.VersionNumber
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.ApplicationServices..::..Application
Autodesk.Revit.DB.Macros..::..ApplicationEntryPoint
Autodesk.Revit.ApplicationServices..::..Application
Autodesk.Revit.DB.Macros..::..ApplicationEntryPoint