An object stored in the Extensible Storage framework. An Entity is described by a Schema,
which serves both to identify an Entity, and to describe its contents (Fields).
Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since:
2012
Syntax
C# |
---|
public class Entity : IDisposable |
Visual Basic |
---|
Public Class Entity _ Implements IDisposable |
Visual C++ |
---|
public ref class Entity : IDisposable |
Remarks
An Entity is similar to an object in most object-oriented languages, while a Schema is the
class of that object.
The Get and Set methods are central - they provide access to the fields of the Entity.
Note that an unitialized Entity retrieved from an Element or another Entity (if it has not
been created yet) will be represented as an invalid entity, not nullNothingnullptra null reference (Nothing in Visual Basic).
If an Element containing an Entity is split (e.g., a wall split), the Entity and its data will exist
in both new Elements.
If an Element containing an Entity is copied, the Element copy will also contain a copy of the Entity and its data.
If an Entity stores an ElementId, and the Element with that ElementId is deleted, the stored
ElementId will automatically be set to ElementId.InvalidElementId (-1).