Revit Preview Release API |
Selection..::..SetElementIds Method |
Selection Class See Also |
Selects the elements.
Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 19.0.0.0 (19.0.0.405)
Since:
2015
Syntax
C# |
---|
public void SetElementIds( ICollection<ElementId> elementIds ) |
Visual Basic |
---|
Public Sub SetElementIds ( _ elementIds As ICollection(Of ElementId) _ ) |
Visual C++ |
---|
public: void SetElementIds( ICollection<ElementId^>^ elementIds ) |
Parameters
- elementIds
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The ids of the elements to be selected.
Remarks
This function will select the specified elements and update the UI.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |