Revit Preview Release API |
View..::..AddFilter Method |
View Class See Also |
Adds a filter to the view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since:
2014
Syntax
C# |
---|
public void AddFilter( ElementId filterElementId ) |
Visual Basic |
---|
Public Sub AddFilter ( _ filterElementId As ElementId _ ) |
Visual C++ |
---|
public: void AddFilter( ElementId^ filterElementId ) |
Parameters
- filterElementId
- Type: Autodesk.Revit.DB..::..ElementId
ElementId of the filter.
Remarks
The filter will be added with default overrides, which means that there will be no change in the view's display.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | ElementId is not associated with a FilterElement. -or- Filter is already applied to the view. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | View does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes. |