Revit Preview Release API |
ExternalService..::..GetDefaultServerId Method |
ExternalService Class See Also |
Returns the Id of the default server if one was assigned to the service.
Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since:
2013
Syntax
C# |
---|
public Guid GetDefaultServerId() |
Visual Basic |
---|
Public Function GetDefaultServerId As Guid |
Visual C++ |
---|
public: Guid GetDefaultServerId() |
Return Value
The GUID of the default server, or an invalid GUID if there is none assigned.
Remarks
Only mandatory services have default servers assigned.
Only built-in service can currently be mandatory. All third-party
services are optional and cannot (amd may not) have default servers.