Revit 2020 API |
Application..::..NewFamilyInstanceCreationData Method (FamilySymbol, IList<(Of <(<'XYZ>)>)>) |
Application Class See Also |
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Syntax
C# |
---|
public FamilyInstanceCreationData NewFamilyInstanceCreationData( FamilySymbol symbol, IList<XYZ> adaptivePoints ) |
Visual Basic |
---|
Public Function NewFamilyInstanceCreationData ( _ symbol As FamilySymbol, _ adaptivePoints As IList(Of XYZ) _ ) As FamilyInstanceCreationData |
Visual C++ |
---|
public: FamilyInstanceCreationData^ NewFamilyInstanceCreationData( FamilySymbol^ symbol, IList<XYZ^>^ adaptivePoints ) |
Parameters
- symbol
- Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
- adaptivePoints
- Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The adaptive point location where the adaptive instance is to be placed.