A class used to iterate individual points in a PointCollection.
Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2012
Syntax
C# |
---|
public class PointIterator : IEnumerator<CloudPoint> |
Visual Basic |
---|
Public Class PointIterator _ Implements IEnumerator(Of CloudPoint) |
Visual C++ |
---|
public ref class PointIterator : IEnumerator<CloudPoint> |
Remarks
Points may be iterated in two different ways:
- In the traditional IEnumerable interface, you can iterate the resulting points directly from the PointCollection.
- In an unsafe interface usable only from C# and C++/CLI, you can get a pointer to the point storage of the collection and access the points directly in memory. Although you must deal with pointers directly, there may be performance improvements when traversing large buffers of points.