Revit 2020 API |
Viewport..::..GetBoxCenter Method |
Viewport Class See Also |
Returns the center of the outline of the viewport on the sheet, excluding the viewport label.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2014
Syntax
C# |
---|
public XYZ GetBoxCenter() |
Visual Basic |
---|
Public Function GetBoxCenter As XYZ |
Visual C++ |
---|
public: XYZ^ GetBoxCenter() |
Return Value
The center of the outline of the viewport on the sheet.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | The viewport is not on a sheet. |