Evaluates and returns the point that matches a parameter along the curve.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Syntax
Visual Basic |
---|
Public Function Evaluate ( _
parameter As Double, _
normalized As Boolean _
) As XYZ |
Visual C++ |
---|
public:
XYZ^ Evaluate(
double parameter,
bool normalized
) |
Parameters
- parameter
- Type: System..::..Double
The parameter to be evaluated.
- normalized
- Type: System..::..Boolean
If false, param is interpreted as natural parameterization of the curve.
If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.
Return Value
The point evaluated along the curve.
Exceptions
See Also