A TopographyEditScope allows an application to create and maintain an editing session for a TopographySurface.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2014
Syntax
Remarks
Start/end of a TopographyEditScope will start/end a transaction group. After a TopographyEditScope is started, an application can start transactions and edit the topography surface.
Individual transactions the application creates inside TopographyEditScope will not appear in the undo menu.
All transactions committed during the edit mode will be merged into a single one which will bear the given name passed into TopographyEditScope constructor.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..EditScope
Autodesk.Revit.DB.Architecture..::..TopographyEditScope
Autodesk.Revit.DB..::..EditScope
Autodesk.Revit.DB.Architecture..::..TopographyEditScope