Revit 2020 API |
Railing..::..SetPath Method |
Railing Class See Also |
Sets the railing path.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2017
Syntax
C# |
---|
public void SetPath( CurveLoop curveLoop ) |
Visual Basic |
---|
Public Sub SetPath ( _ curveLoop As CurveLoop _ ) |
Visual C++ |
---|
public: void SetPath( CurveLoop^ curveLoop ) |
Parameters
- curveLoop
- Type: Autodesk.Revit.DB..::..CurveLoop
The railing path along which the new railing will be created. The curveLoop should be continuous with curves which are only bounded lines and arcs on the same horizontal plane. It also has to have maximum two curves meet in one end point.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The curveLoop must be a single connected path, located on the same horizontal plane and defined using lines or arcs only. It also has to have maximum two curves meet in one end point. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InapplicableDataException | The railing has incorrect internal data. |