This class is used to search, filter and iterate through a set of worksets.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2012
Syntax
C# |
---|
public class FilteredWorksetCollector : IEnumerable<Workset>, IDisposable |
Visual Basic |
---|
Public Class FilteredWorksetCollector _ Implements IEnumerable(Of Workset), IDisposable |
Visual C++ |
---|
public ref class FilteredWorksetCollector : IEnumerable<Workset^>, IDisposable |
Remarks
Developers can assign a condition to filter the worksets that are returned. If no condition is applied, it attempts to access all the worksets in the document.
The collector will reset if you call another method to extract worksets. Thus, if you have previously obtained an iterator, it will be stopped and traverse no more worksets if you call another method to extract worksets.