Revit 2020 API |
BoundingBoxIntersectsFilter Constructor (Outline) |
BoundingBoxIntersectsFilter Class See Also |
Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2011
Syntax
C# |
---|
public BoundingBoxIntersectsFilter( Outline outline ) |
Visual Basic |
---|
Public Sub New ( _ outline As Outline _ ) |
Visual C++ |
---|
public: BoundingBoxIntersectsFilter( Outline^ outline ) |
Parameters
- outline
- Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that intersect it.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |