Revit 2020 API |
Units..::..GetModifiableUnitTypes Method |
Units Class See Also |
Gets all unit types for which the default FormatOptions can be modified.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2014
Syntax
C# |
---|
public static IList<UnitType> GetModifiableUnitTypes() |
Visual Basic |
---|
Public Shared Function GetModifiableUnitTypes As IList(Of UnitType) |
Visual C++ |
---|
public: static IList<UnitType>^ GetModifiableUnitTypes() |
Return Value
The unit types for which the FormatOptions can be modified.
Remarks
The Units class stores a FormatOptions object for every valid unit
type, but not all of them can be directly modified. Some, like
UT_Number and UT_SiteAngle, have fixed definitions. Others have
definitions which are automatically derived from other unit types.
For example, UT_SheetLength is derived from UT_Length and
UT_ForceScale is derived from UT_Force.