Revit 2020 API |
Application..::..NewXYZ Method (Double, Double, Double) |
Application Class See Also |
Creates a XYZ object representing coordinates in 3-space with supplied values.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Syntax
C# |
---|
public XYZ NewXYZ( double x, double y, double z ) |
Visual Basic |
---|
Public Function NewXYZ ( _ x As Double, _ y As Double, _ z As Double _ ) As XYZ |
Visual C++ |
---|
public: XYZ^ NewXYZ( double x, double y, double z ) |
Parameters
- x
- Type: System..::..Double
The first coordinate.
- y
- Type: System..::..Double
The second coordinate.
- z
- Type: System..::..Double
The third coordinate.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting an infinite number to the X, Y or Z property. |