Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2013
Syntax
C# |
---|
public class TriangulatedSolidOrShell : IDisposable |
Visual Basic |
---|
Public Class TriangulatedSolidOrShell _ Implements IDisposable |
Visual C++ |
---|
public ref class TriangulatedSolidOrShell : IDisposable |
Remarks
The triangulation consists of a number of TriangulatedShellComponents. For a solid, there will be one TriangulatedShellComponent for each component of the solid's boundary. For example, a solid cube has just one boundary component (containing six faces), so there will be just one TriangulatedShellComponent. A solid consisting of two disjoint cubes has two boundary components (the boundaries of the two cubes), so there will be two TriangulatedShellComponents. A solid consisting of a sphere with a round void (or hole) inside it also has two boundary components (the outer sphere and the inner sphere), so there will be two TriangulatedShellComponents.
For a shell, there will be one TriangulatedShellComponent for each component of the shell.
Note that this class does not contain information on the containment structure of the boundary components of a solid.
Be careful not to confuse the components of a solid with the solid's boundary components. This class deals only with the boundary components.