Revit 2020 API |
FilterCategoryRule Constructor |
FilterCategoryRule Class See Also |
Constructs a new instance of FilterCategoryRule.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2014
Syntax
C# |
---|
public FilterCategoryRule( ICollection<ElementId> categories ) |
Visual Basic |
---|
Public Sub New ( _ categories As ICollection(Of ElementId) _ ) |
Visual C++ |
---|
public: FilterCategoryRule( ICollection<ElementId^>^ categories ) |
Parameters
- categories
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of categories.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |