Revit 2020 API |
Face..::..ComputeDerivatives Method |
Face Class See Also |
Returns the first partial derivatives of the underlying surface at the specified point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Syntax
C# |
---|
public Transform ComputeDerivatives( UV point ) |
Visual Basic |
---|
Public Function ComputeDerivatives ( _ point As UV _ ) As Transform |
Visual C++ |
---|
public: Transform^ ComputeDerivatives( UV^ point ) |
Parameters
- point
- Type: Autodesk.Revit.DB..::..UV
The parameters to be evaluated, in natural parameterization of the face.
Return Value
A transformation containing tangent vectors and a normal vector.
Remarks
The following is the meaning of the transformation members:
- Origin is the point on the face (equivalent to Evaluate(UV));
- BasisX is the tangent vector along the U coordinate (partial derivative with respect to U).
- BasisY is the tangent vector along the V coordinate (partial derivative with respect to V).
- BasisZ is the underlying surface's normal vector. This is not necessarily aligned with the normal vector pointing out of a solid that contains the face, to get that value use ComputeNormal(UV).