Revit 2020 API |
Autodesk.Revit.DB.ExtensibleStorage Namespace |
Classes
Class | Description | |
---|---|---|
![]() | DataStorage |
An element which allows an API applications to organize and store data.
|
![]() | Entity |
An object stored in the Extensible Storage framework. An Entity is described by a Schema,
which serves both to identify an Entity, and to describe its contents (Fields).
|
![]() | ExtensibleStorageFilter |
A filter used to filter elements with extensible storage data based on specific Schema id.
|
![]() | Field |
The description of a field within a Schema in the Extensible Storage framework. Contains
the field's name, type, access control and documentation.
|
![]() | FieldBuilder |
This class is used to create Fields in the Extensible Storage framework.
|
![]() | Schema |
The description of a single object (Entity) in the Extensible Storage framework. Contains
identity information, documentation and the list of fields to be stored in the Entity.
|
![]() | SchemaBuilder |
This class is used to create Schemas in the Extensible Storage framework.
|
Enumerations
Enumeration | Description | |
---|---|---|
![]() | AccessLevel |
Defines access levels to objects in the Extensible Storage framework.
|
![]() | ContainerType |
An enumerated type indicating if the field represents a single value or a container of multiple values.
|