An object that contains overrides for external resource-specific methods.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2015
Syntax
C# |
---|
public class ExternalResourceServerExtensions : IDisposable |
Visual Basic |
---|
Public Class ExternalResourceServerExtensions _ Implements IDisposable |
Visual C++ |
---|
public ref class ExternalResourceServerExtensions : IDisposable |
Remarks
This class permits assignment of some specific operations related to a type of external resource, such as what to do when "Open (and Unload)" happens, or when "Shared Coordinates update" happens for Revit or CAD links.
There is no feedback to the UI server for ExternalResourceServerExtensions. Revit will use standard, common message dialogs to handle any error conditions.