A system type in the Autodesk Revit MEP product.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2012
Syntax
C# |
---|
public class MEPSystemType : ElementType |
Visual Basic |
---|
Public Class MEPSystemType _ Inherits ElementType |
Visual C++ |
---|
public ref class MEPSystemType : public ElementType |
Remarks
This is the base class for mechanical and piping system types,
available only in the Autodesk Revit MEP product.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..MEPSystemType
Autodesk.Revit.DB.Mechanical..::..MechanicalSystemType
Autodesk.Revit.DB.Plumbing..::..PipingSystemType
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..MEPSystemType
Autodesk.Revit.DB.Mechanical..::..MechanicalSystemType
Autodesk.Revit.DB.Plumbing..::..PipingSystemType