Revit 2020 API |
FormatOptions..::..IsValidForUnitType Method |
FormatOptions Class See Also |
Checks whether this FormatOptions is valid for a given unit type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2014
Syntax
C# |
---|
public bool IsValidForUnitType( UnitType unitType ) |
Visual Basic |
---|
Public Function IsValidForUnitType ( _ unitType As UnitType _ ) As Boolean |
Visual C++ |
---|
public: bool IsValidForUnitType( UnitType unitType ) |
Parameters
- unitType
- Type: Autodesk.Revit.DB..::..UnitType
The unit type.
Return Value
True if the FormatOptions is valid, false otherwise.
Remarks
The FormatOptions is valid if UseDefault is true or if the display
unit in the FormatOptions is valid for the unit type. See
UnitUtils.IsValidDisplayUnit(UnitType, DisplayUnitType)
and
UnitUtils.GetValidDisplayUnits(UnitType).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | unitType is an invalid unit type. See UnitUtils.IsValidUnitType() and UnitUtils.GetValidUnitTypes(). |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |