A filter used to match areas.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Syntax
C# |
---|
public class AreaFilter : ElementSlowFilter |
Visual Basic |
---|
Public Class AreaFilter _ Inherits ElementSlowFilter |
Visual C++ |
---|
public ref class AreaFilter : public ElementSlowFilter |
Remarks
This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements
before the elements are obtained and expanded. Therefore this filter does not have to be
paired with another quick filter to minimize the number of Elements that are expanded.
Examples

// Use a AreaFilter to find all area elements in the document. It is necessary to use the AreaFilter, // and not an ElementClassFilter or the shortcut method OfClass() because the area class is not // supported by those methods. AreaFilter filter = new AreaFilter(); // Apply the filter to the elements in the active document FilteredElementCollector collector = new FilteredElementCollector(document); IList<Element> areas = collector.WherePasses(filter).ToElements();

' Use a AreaFilter to find all area elements in the document. It is necessary to use the AreaFilter, ' and not an ElementClassFilter or the shortcut method OfClass() because the area class is not ' supported by those methods. Dim filter As New AreaFilter() ' Apply the filter to the elements in the active document Dim collector As New FilteredElementCollector(document) Dim areas As IList(Of Element) = collector.WherePasses(filter).ToElements()
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..AreaFilter
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..AreaFilter