Manages default pipe segments, fittings, and selection criteria for a given MEPCurveType
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2013
Syntax
C# |
---|
public class RoutingPreferenceManager : IDisposable |
Visual Basic |
---|
Public Class RoutingPreferenceManager _ Implements IDisposable |
Visual C++ |
---|
public ref class RoutingPreferenceManager : IDisposable |
Remarks
MEPCurveTypes contain a RoutingPreferenceManager property.
The RoutingPreferenceManager contains rules for selecting segment types and sizes as well as fitting types based on user selection criteria.