IsRuleEnabled Method (Int32)
Retrieves an enabled/disabled status for the given rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:  2012

Syntax

C#
public bool IsRuleEnabled(
	int index
)
Visual Basic
Public Function IsRuleEnabled ( _
	index As Integer _
) As Boolean
Visual C++
public:
bool IsRuleEnabled(
	int index
)

Parameters

index
Type: System..::..Int32
The rule index to retrieve enabled/disabled status for.

Return Value

True if rule is disabled, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException The index is outside of acceptable range.

See Also