Revit 2020 API |
Curve..::..SetGraphicsStyleId Method |
Curve Class See Also |
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Syntax
C# |
---|
public void SetGraphicsStyleId( ElementId id ) |
Visual Basic |
---|
Public Sub SetGraphicsStyleId ( _ id As ElementId _ ) |
Visual C++ |
---|
public: void SetGraphicsStyleId( ElementId^ id ) |
Parameters
- id
- Type: Autodesk.Revit.DB..::..ElementId
The id of the GraphicsStyle element from which to apply the curve properties.
Remarks
If the curve is marked as read-only (because it was extracted directly from a Revit element or collection/aggregation object), calling this method causes the object to be changed to carry a disconnected copy of the original curve. The modification will not affect the original curve or the object that supplied it.
Many methods in the Revit API will not use the graphics style associated to this curve. For example, curves used as portions of the sketch of an element will not read this property. Newly created curve elements will not use this value either, as they inherit their graphical properties from their associated category.