Revit 2020 API |
PerformanceAdviser..::..GetRuleName Method (PerformanceAdviserRuleId) |
PerformanceAdviser Class See Also |
Retrieves the name of the rule.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2012
Syntax
C# |
---|
public string GetRuleName( PerformanceAdviserRuleId id ) |
Visual Basic |
---|
Public Function GetRuleName ( _ id As PerformanceAdviserRuleId _ ) As String |
Visual C++ |
---|
public: String^ GetRuleName( PerformanceAdviserRuleId^ id ) |
Parameters
- id
- Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The rule id to get information for.
Return Value
The name of the rule.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |