Revit 2020 API |
FormatOptions..::..UnitSymbol Property |
FormatOptions Class See Also |
The unit symbol that should be displayed to indicate the units of the value.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2014
Syntax
C# |
---|
public UnitSymbolType UnitSymbol { get; set; } |
Visual Basic |
---|
Public Property UnitSymbol As UnitSymbolType Get Set |
Visual C++ |
---|
public: property UnitSymbolType UnitSymbol { UnitSymbolType get (); void set (UnitSymbolType value); } |
Field Value
The unit symbol. The default is UST_NONE.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: unitSymbol is not a valid unit symbol for the display unit in this FormatOptions. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions. |