Revit 2020 API |
RebarContainer..::..SetItemHiddenStatus Method |
RebarContainer Class See Also |
Sets the RebarContainerItem to be hidden or unhidden in the given view.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2017
Syntax
C# |
---|
public void SetItemHiddenStatus( View view, int itemIndex, bool hide ) |
Visual Basic |
---|
Public Sub SetItemHiddenStatus ( _ view As View, _ itemIndex As Integer, _ hide As Boolean _ ) |
Visual C++ |
---|
public: void SetItemHiddenStatus( View^ view, int itemIndex, bool hide ) |
Parameters
- view
- Type: Autodesk.Revit.DB..::..View
The view.
- itemIndex
- Type: System..::..Int32
Item index in the Rebar Container.
- hide
- Type: System..::..Boolean
True to hide this RebarContainerItem in the view, false to unhide the item.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The item index is either less than 0 or graeter than or equal to number of items in this Rebar Container element. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |