Revit 2020 API |
WallType..::..ThermalProperties Property |
WallType Class See Also |
The calculated and settable thermal properties of the WallType
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2013
Syntax
C# |
---|
public ThermalProperties ThermalProperties { get; } |
Visual Basic |
---|
Public ReadOnly Property ThermalProperties As ThermalProperties Get |
Visual C++ |
---|
public: property ThermalProperties^ ThermalProperties { ThermalProperties^ get (); } |
Remarks
Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the wall has no thermal properties.
Curtain walls and stacked walls do not store thermal properties.