GetRuleParameter Method
Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:  2019

Syntax

C#
public ElementId GetRuleParameter()
Visual Basic
Public Function GetRuleParameter As ElementId
Visual C++
public:
ElementId^ GetRuleParameter()

Return Value

The parameter id if there is an associated parameter, or invalidElementId if not.

See Also