Revit 2021.1 API |
RevitLinkInstance..::..MoveBasePointToHostBasePoint Method |
RevitLinkInstance Class See Also |
Moves this link instance so that the base point in the linked document is aligned to the base point in the host document. This is a one-time movement and does not set up any shared coordinates relationship.
If the rotation angle of this link instance was changed after insertion, the rotation angle can be preserved or reset to the original insertion angle.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2016 SubscriptionUpdate
Syntax
C# |
---|
public void MoveBasePointToHostBasePoint( bool resetToOriginalRotation ) |
Visual Basic |
---|
Public Sub MoveBasePointToHostBasePoint ( _ resetToOriginalRotation As Boolean _ ) |
Visual C++ |
---|
public: void MoveBasePointToHostBasePoint( bool resetToOriginalRotation ) |
Parameters
- resetToOriginalRotation
- Type: System..::..Boolean
Sets to true if:
- restoring the original insertion angle of the link instance after it is moved if there was a rotation \ mirror transform on the link instance.
- there was no a rotation \ mirror transform on the link instance.
Sets to false to retain the current angle of the link instance after it is moved if there was a rotation \ mirror transform on the link instance.
Remarks
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | This RevitLinkInstance is not an instance of a loaded RevitLinkType. -or- This RevitLinkInstance is not an instance of a top-level RevitLinkType. -or- The operation is not permitted because the element is pinned. |