Revit 2021.1 API |
Element..::..GetParameterFormatOptions Method |
Element Class See Also |
Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2014
Syntax
C# |
---|
public FormatOptions GetParameterFormatOptions( ElementId parameterId ) |
Visual Basic |
---|
Public Function GetParameterFormatOptions ( _ parameterId As ElementId _ ) As FormatOptions |
Visual C++ |
---|
public: FormatOptions^ GetParameterFormatOptions( ElementId^ parameterId ) |
Parameters
- parameterId
- Type: Autodesk.Revit.DB..::..ElementId
Id of parameter for which FormatOptions will be returned.
Return Value
Format options of element parameter. If the UseDefault property is true, then no formatting overrides have been defined in the element for the specified parameter, and the FormatOptions for the parameter should be obtained from the Unit object, which can be obtained from the Document.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |