GetCoverType Method
Gets the CoverType associated with a face of the element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public RebarCoverType GetCoverType(
	Reference face
)
Visual Basic
Public Function GetCoverType ( _
	face As Reference _
) As RebarCoverType
Visual C++
public:
RebarCoverType^ GetCoverType(
	Reference^ face
)

Return Value

The cover associated with the face, if it is an exposed face. If the face is concealed, returns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also