Revit 2021.1 API |
Element..::..GetDependentElements Method |
Element Class See Also |
Get all elements that, from a logical point of view, are the children of this Element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2018.1
Syntax
C# |
---|
public IList<ElementId> GetDependentElements( ElementFilter filter ) |
Visual Basic |
---|
Public Function GetDependentElements ( _ filter As ElementFilter _ ) As IList(Of ElementId) |
Visual C++ |
---|
public: IList<ElementId^>^ GetDependentElements( ElementFilter^ filter ) |
Parameters
- filter
- Type: Autodesk.Revit.DB..::..ElementFilter
What type of elements we are interested of. Can be NULL to return all dependent elements.
Return Value
Logical children of this element
Remarks
The elements that this method will return:
- Will be deleted if the input Element is deleted.
- Potentially could report the input Element as a host (there could be other type of parent/child relationship here: for example view/view-specific elements, etc.)