Definition of a shape whose size and position can determined by a single arc.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2009
Syntax
C# |
---|
public class RebarShapeDefinitionByArc : RebarShapeDefinition |
Visual Basic |
---|
Public Class RebarShapeDefinitionByArc _ Inherits RebarShapeDefinition |
Visual C++ |
---|
public ref class RebarShapeDefinitionByArc : public RebarShapeDefinition |
Remarks
In this shape definition, all dimensions are allowed to be driving dimensions.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeDefinition
Autodesk.Revit.DB.Structure..::..RebarShapeDefinitionByArc
Autodesk.Revit.DB.Structure..::..RebarShapeDefinition
Autodesk.Revit.DB.Structure..::..RebarShapeDefinitionByArc