Creates a new geometric arc object based on plane, radius, and angles.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2014
Syntax
C# |
---|
public static Arc Create(
Plane plane,
double radius,
double startAngle,
double endAngle
) |
Visual Basic |
---|
Public Shared Function Create ( _
plane As Plane, _
radius As Double, _
startAngle As Double, _
endAngle As Double _
) As Arc |
Visual C++ |
---|
public:
static Arc^ Create(
Plane^ plane,
double radius,
double startAngle,
double endAngle
) |
Parameters
- plane
- Type: Autodesk.Revit.DB..::..Plane
The plane which the arc resides. The plane's origin is the center of the arc.
- radius
- Type: System..::..Double
The radius of the arc.
- startAngle
- Type: System..::..Double
The start angle of the arc (in radians).
- endAngle
- Type: System..::..Double
The end angle of the arc (in radians).
Return Value
The new arc.
Remarks
Examples
CopyC#
Arc CreateArcByGivingPlane(Autodesk.Revit.ApplicationServices.Application application, Plane plane)
{
double radius = 10;
double startAngle = 0;
double endAngle = 2 * Math.PI;
return Arc.Create(plane, radius, startAngle, endAngle);
}
CopyVB.NET
Private Function CreateArcByGivingPlane(application As Autodesk.Revit.ApplicationServices.Application, plane As Plane) As Arc
Dim radius As Double = 10
Dim startAngle As Double = 0
Dim endAngle As Double = 2 * Math.PI
Return Arc.Create(plane, radius, startAngle, endAngle)
End Function
Exceptions
See Also